Translation other than english eats cpu and ram

Oct 22, 2012 at 7:24 AM
Edited Oct 22, 2012 at 7:27 AM

Hi, there,

I have a problem with Squiggle 3.1.6. I'll try to explain with my bad English.  

I can not use Translation.xaml other than original english.

 squiggle comes up but as soon as a connection is found, then it freezes with min. 50% cpu and eat RAM endless. (i see it in taskmanager). It works only with the English version.


i tried it with german and french. (german is found in source code section ;-))

Please can me anyone give a little enlightement? Have testet it with various machines (Win7 64 and net framework 4)

 

Coordinator
Oct 22, 2012 at 7:29 AM

Hi

The freeze happens only when you put non English characters in Translation.xaml?

Oct 22, 2012 at 7:47 AM

Hi……..wau, thats service,

hmmmm wat is non english character? You mean geman “ä , ö , ü” ?

I have testet your german version in the source codes….., my german (have send it a few days before), and the “french” version (they have no german “ä,ö,ü)

Here, there is a screenshot from my notebook after 2 Minutes running

This effect is only AFTER a connection to another client is there. alone, nothing happens, only when one tries to find a contact

Have you a idea?

Von: hasankhan [email removed]
Gesendet: Montag, 22. Oktober 2012 09:30
An: atmlos@gmx.de
Betreff: Re: Translation other than english eats cpu and ram [squiggle:400261]

From: hasankhan

Hi

The freeze happens only when you put non English characters in Translation.xaml?

Coordinator
Oct 22, 2012 at 7:49 AM

Do you get this error only when you try to change Translation.xaml file? If you leave it the way it was then you don't have problems. If you add any german characters then make sure they are properly encoded. You can use http://coderstoolbox.net/string/ for encoding.

Oct 22, 2012 at 8:10 AM

Hmmmm…… i can try it,

But it is the same effect with your original files from here

I have download the source, extract this files…..without any changes and then I have this effects…….

I'm not a programmer, and am irritated because where the error should be.

Please try some themselves from your translation files… and I test your link….

Von: hasankhan [email removed]
Gesendet: Montag, 22.
Oktober 2012 09:49
An: atmlos@gmx.de
Betreff:
Re: Translation other than english eats cpu and ram [squiggle:400261]

From: hasankhan

Do you get this error only when you try to change Translation.xaml file? If you leave it the way it was then you don't have problems. If you add any german characters then make sure they are properly encoded. You can use http://coderstoolbox.net/string/ for encoding.

Oct 22, 2012 at 10:21 AM
Edited Oct 22, 2012 at 10:24 AM

Strange, but success.


I have take your original english file and with the help of the free editorKaxaml” , I make my own Translation.

 

This file works!

 

Although I do not see the error (I am not a programmer ).

 

At the end, I still have the top line (.. .. utf-8 encoding ....) inserted (I need it?)

and my version has 212 lines (with this "utf-8"-line), the original german 206 i mean ... can this be! (e.g. in the smileys)

 

 

 

Von: hasankhan [email removed]
Gesendet: Montag, 22. Oktober 2012 09:49
An: atmlos@gmx.de
Betreff: Re: Translation other than english eats cpu and ram [squiggle:400261]

 

From: hasankhan

Do you get this error only when you try to change Translation.xaml file? If you leave it the way it was then you don't have problems. If you add any german characters then make sure they are properly encoded. You can use http://coderstoolbox.net/string/ for encoding.