Turn Off File Transfer Function

May 4, 2012 at 2:45 AM

Hai all, any body can help me to turn off file function on Squigglethanks

pls also PM to riyan_182cs@yahoo.com

Feb 20, 2013 at 12:58 PM
I need help turning in on. Can anyone post how to turn this feature on and off?

Thanks
Coordinator
Feb 20, 2013 at 1:21 PM
Riyan: You can turn off the feature by removing the file transfer dll from plugins directory.
Steve: You can turn it on by putting it back. If the dll is there but you can't see the option enabled then Squiggle may not have access to Plugins folder.
Feb 20, 2013 at 1:24 PM
hasankhan wrote:
Steve: You can turn it on by putting it back. If the dll is there but you can't see the option enabled then Squiggle may not have access to Plugins folder.
How do I make it so Squiggle does have access? Currently, the security settings on the Plugins folder says Everyone has Modify access. Is there anything else that needs to be done?
Coordinator
Feb 20, 2013 at 1:27 PM
Can you copy and run squiggle instance locally to see if the file transfer feature is enabled for you?
Feb 20, 2013 at 1:31 PM
No, copying it locally and running the local .exe. file has no affect. The file transfer button is still grayed out.
Coordinator
Feb 20, 2013 at 1:42 PM
Did you also copy the plugin folder? Are you developer? Can you debug this on your machine?
Feb 20, 2013 at 1:54 PM
Yeah, I copied the entire folder, which contains all the .exes, the .dlls, plugins folder, etc.

Sadly, I'm am not a developer, so figuring out issues with such as this one requires assistance. I'm an IT guy at my company. I believe in the past, I have tried to re-download the client to make this work, but nothing changes. Is there something in the config file that may be preventing this? I did change some stuff, but I don't think I disabled anything.




PS: This is a little off topic, but it may be related. I noticed that my Squiggle says there's an update available. On the Downloads pages, it says you updated it on the 18th, but yet the downloadable files say they were uploaded in December. Will downloading those clients give me the update?
Coordinator
Feb 20, 2013 at 2:05 PM
The update on the site was not update to the client but to the page. So no downloading it again won't help. Unfortunately the only way to debug this issue is to find out what is happening in the code. For me it works fine and I'm unable to reproduce it. There is no setting that you could have turned off by mistake to disable file transfer. I'm suspecting the only problem is that Squiggle is not able to find the plugins folder.

Does running the program as administrator help?
Feb 20, 2013 at 2:12 PM
Oh, alright, I see.

I ran the .exe directly from two machines, both running as administrator, but no change. I'm going to try and download some local clients and see if I can either get it work, or replicate the error. I'll keep you updated.
Feb 20, 2013 at 2:25 PM
After downloading brand new clients from the site, running as administrator, and confirm the Filetransfer plugin was located in the Plugin folder, still the Send File button is grayed out when the two new clients tried talking to each other.

I'm all out of ideas...
Mar 1, 2013 at 9:19 PM
I have Squiggle on a 4 Win7 network. All set up the same and running from a folder. One machine has file transfer and the other three are grayed out. Yes filetransfer dll is present on all four. No clue.
Coordinator
Mar 1, 2013 at 9:27 PM
Syngensmyth you're also running from a shared network folder?
Mar 25, 2013 at 2:52 PM
Any update on this? I recently resetup my company's Squiggle client on a new server on a different subnet with freshly downloaded clients from the site, and still the File Transfer button is grayed out all the time.
Coordinator
Mar 25, 2013 at 2:59 PM

Hi Steve

Unfortunately I'm unable to reproduce this locally.

If you have a developer in your company then I'd recommend you to ask him to debug this and contribute a fix.

Mar 27, 2013 at 2:21 PM
Edited Mar 27, 2013 at 2:24 PM
TURN ON FILE TRANSFER OPTION - I THINK I FOUND IT!!!

I tried all the suggestions above as well - with no success. I have windows 7 on this machine as well. Then I:

1) Right clicked on the individual .dll file(s) in the plugins folder.
2) Click on Properties
3) At the bottom of the Properties Window that opens - the bottom option - SECURITY - reads: "This file came from another computer and might be blocked to help protect this computer." with a button next to it that says "Unblock" on it. I CLICKED IT.
4) It now works for me.

It's a one-time deal. Once I clicked the UNBLOCK button - not only did it apparently ENABLE the use of the .dll file - but that specific SECURITY option didn't appear when I re-opened the properties window to review what I'd done.

That security option happened to be on all the .dll files in the plugins folder.

I hope it works for you, too!
Coordinator
Mar 27, 2013 at 2:32 PM
Thank you for sharing the solution with us.
Mar 27, 2013 at 2:37 PM
You’re quite welcome. I hope it works for the others, too!
From: [email removed]
Sent: Wednesday, March 27, 2013 10:32 AM
To: [email removed]
Subject: Re: Turn Off File Transfer Function [squiggle:354487]

From: hasankhan

Thank you for sharing the solution with us.
Mar 27, 2013 at 2:53 PM
Edited Mar 27, 2013 at 2:53 PM
Flexible wrote:
TURN ON FILE TRANSFER OPTION - I THINK I FOUND IT!!!

I tried all the suggestions above as well - with no success. I have windows 7 on this machine as well. Then I:

1) Right clicked on the individual .dll file(s) in the plugins folder.
2) Click on Properties
3) At the bottom of the Properties Window that opens - the bottom option - SECURITY - reads: "This file came from another computer and might be blocked to help protect this computer." with a button next to it that says "Unblock" on it. I CLICKED IT.
4) It now works for me.

It's a one-time deal. Once I clicked the UNBLOCK button - not only did it apparently ENABLE the use of the .dll file - but that specific SECURITY option didn't appear when I re-opened the properties window to review what I'd done.

That security option happened to be on all the .dll files in the plugins folder.

I hope it works for you, too!
Sadly, when right-clicking my .dll files, no such button or message is shown in any tab. It looks like my issue may be a different issue than yours :(

I got really excited for a minute there. Thanks for the reply anyway.
Mar 27, 2013 at 5:22 PM
Edited Mar 27, 2013 at 5:25 PM
Well, I'll relay this step I did first. I thought it was insignificant at the time because the file transfer button was still grayed out after I completed it - but I suppose it could be a two part process.

I right clicked on the plugins folder. Clicked on properties. At the bottom of the Plugins Properties window next to Attributes the "READ-ONLY" box is selected. I tried de-selecting it and clicked APPLY. Only to come back and find that it was still selected when I re-opened the Plugins Properties window.

Like stated above, "security settings on the Plugins folder says Everyone has Modify access" for me, too.

I decided to explore further and clicked on the SHARING tab of the Plugins Properties window. I selected/clicked on ADVANCED SETTINGS. I don't recall now if "Share this folder" was already selected, or if I had to select it. In the same window, Under Settings, Share name:, "PLUGINS" was selected by default in drop down menu. I clicked on "Permissions" button below it - near the bottom. Opened a SHARE PERMISSIONS window, under Group or user names: "Everyone" was the only thing listed, so I left it like that. However, below, I discovered only the READ box was checked in the Allow column. So I also checked "Full Control" and "Change" in the Allow Column as well. Clicked ok to exit, etc.

Incidentally, It still has the Read-only box selected when I open the Plugins Properties folder.... but when I check on the new boxes that I selected under Advanced Settings of the Sharing tab - those STILL show they are selected, now. So perhaps it does SOMETHING different.

I don't know if that will make a difference for you - but that IS something I DID just before the other step mentioned above and neglected to mention.
Oct 8, 2014 at 9:10 AM
Edited Oct 8, 2014 at 9:20 AM
I found solution provided by flexible was cool.Check out the reference link given below , shows how to unblock files :

http://www.sevenforums.com/tutorials/124367-open-file-security-warning-unblock-file.html

*for saferside check taskmanager to make sure that squiggle instance is not running...

Thanks Flexible
Nov 18, 2014 at 8:18 AM
hI,
I want to turn off or disable the file transfer option . i tried removing the filetrasfer dll fro the plugin folder but on doing so it does not allow sign in. It shows "using single sign on". and nothing happens on clicking on the sign on button. can anyone help
Coordinator
Nov 18, 2014 at 4:29 PM
Can you list the names of dlls that you removed?
Nov 26, 2014 at 6:42 AM
hasankhan wrote:
Can you list the names of dlls that you removed?
Your message:
Hi,
I removed the Squiggle.FileTransfer.dll from the Plugins folder.
I have 8 computers connected in local network and need the chat feature without file transfer feature.
Presently if I remove the above mentioned dll, on launching application it shows "Single User logon" and doesn't allow Login.. Kindly help.
Coordinator
Nov 26, 2014 at 2:19 PM
Please also delete ScreenShot.dll as it is depends on FileTransfer.dll
Mar 9, 2015 at 9:58 AM
Hi,
Thanks to your suggestion we were able to use squiggle without file transfer. Its now on our network PCs. But one major problem was discovered that the contact list is not auto refreshing. So any new user who starts his system doesn't show up in the messenger list automatically. Only If we re-sign we are able to see him. Some times few users are seen and if we re-sign in then it shows all people online. I found this on both 3.3 and 3.4 versions. Actually any user if signs in on his machine start up or launch messenger anytime, the messenger should detect and refresh all users automatically. This seems to be quite an hinderance. Can I do anything to get this fixed as we like to continue with this messenger since it has better features.
Thanks in advance.