1
Vote

Not starting up on Windows 8 boot.

description

I have the option set for squiggle to start automatically on boot, however some of my Windows 8 computers don't start the program.

I have tried various things, such as run as administrator, install as administrator, changing permissions to allow my user and administrator to run the program to no avail.

I am using the .msi release of the latest squiggle 3.2. The systems in question are all Windows 8 x64.

comments

hasankhan wrote Aug 28, 2013 at 1:27 PM

I am unable to reproduce the issue on Windows 8. It starts up just fine for me. Please try the following to put it in startup

http://www.fixkb.com/2013/03/how-to-add-start-items-to-windows-8.html

** Closed by hasankhan 08/28/2013 5:27AM

Dodgexander wrote Sep 9, 2013 at 12:11 AM

I have tried placing a shortcut there also and it doesn't work.

Funny thing is, windows itself reports it should start, but it just doesn't.

See the the screenshot: ImageThere are two entries, because 1 is for the setting within Squiggles preferences and the other is where I placed the shortcut as advised. Neither result in squiggle starting.

I have no problems with any other programs starting, but this seems to affect a lot of machines I have tested on. Could it be some way that the installer (.msi) version controls permissions?

I know user permissions etc has changed a lot recently.

hasankhan wrote Sep 9, 2013 at 6:14 AM

Since it is showing up in task manager then it means it is running for sure. You may want to enable debug logs to see if it logs any errors. Read the FAQ to find out how to enable debug logs.

Dodgexander wrote Sep 9, 2013 at 8:53 PM

Please view my screenshot in more detail, it shows the startup tab of task manager *(new in windows 8). Not running processes.

There is a problem with permissions somewhere. When I extract and run squiggle for a location on my computer, in loads on Windows startup fine.

Its when I use the .msi installation and install it somewhere such as program files that it fails.

What permissions in windows 8 does squiggle require to run?

Have you repeated the issue using the .msi installation and to program files?

hasankhan wrote Sep 10, 2013 at 5:06 AM

Squiggle doesn't require any special permissions to run. I'd assume your user doesn't have administrator privilege and program files is a protected location.

This is more of an environment issue than Squiggle itself. I'm afraid there is nothing that can be changed in Squiggle to address this. Please feel free to continue discussion in the discussion area.

hasankhan wrote Sep 10, 2013 at 5:07 AM

** Closed by hasankhan 09/09/2013 9:07PM

Dodgexander wrote Sep 10, 2013 at 7:24 AM

I don't think that's correct, when I extract the .zip release of squiggle, create a program folder in program files myself, the startup runs fine.

When I install using the .msi, the program doesn't run on startup.

Of course I have admin rights, so that is not the problem.

The problem obviously relates to the .msi release somehow. Perhaps also to do with windows 8.

Have you tested installing the .msi release on windows 8 x64?

Dodgexander wrote Sep 10, 2013 at 8:49 PM

If you run the the extracted client it starts with windows fine.

If you run the installed .msi version of the client it doesn't start with windows.

I cant see how this is related to either of those two issues.