Unable to get voice chat working on Squiggle v3.1.6 / v3.2

Dec 14, 2012 at 12:50 PM

I haven't been able to get Voice chat working on Squiggle v3.1.6 or v3.2.

  • I have a Multicast server setup to help overcome a problem with a few of the nodes unable to send messages to the others.
  • I am able to chat to another node and all other features work.
  • I can hear the notification noises for the calls and new messages but no voice is transmitted. 
  • Mic / speaker is working in other applications.

I am trying to setup a demo of squiggle to show my manager so we can roll out squiggle to our whole department. ~25nodes. I am very impressed with squiggle and would like to show off all of it's features. So If anyone can shed some light on the voice configuration it would be graciously received. 

Dec 14, 2012 at 1:00 PM

Squiggle voice chat doesn't require any special configuration. If you're unable to get voice chat to work in any of the machines then probably the issue is with the audio settings of the machines. Can you try different pairs of machines for testing voice chat?

Dec 14, 2012 at 1:01 PM

Yes I have tried combinations of 4 separate machines.

Ill do some investigating and try to provide some more information.

Dec 14, 2012 at 2:25 PM

Thank you for the fast response btw.

Could you suggest anything specific that would help diagnosis?

Some config info:

  • Windows 7
  • Device Audio : Dell Computer 7 Series/C216 Chipset Family High Definition Audio Controller (Microsoft certified drivers)
  • Using headset

I noticed that in 3.1 there is no plugins folder, which is were the voice dll is found in 3.2 (however I assume this is correct) 

Could it be to do with the codecs or lack off codecs?



Jan 8, 2013 at 4:34 PM

I solved this issue. Here is what I found for the record.

It was because the receiving machine did not have a mic plugged in! This meant that the call could not be initialized. 

Is this possibly a bug? I would expect that call can be setup and voice transmitted if a receiving node only has speakers.



Jan 16, 2013 at 1:13 PM

So has this been decided as a bug or a feature?  

Jan 16, 2013 at 1:16 PM

I just wanted to share what I had found when trying to solve this configuration issue. 

I have no idea if its a bug or a feature.