Squiggle.Bridge not function correctly

Sep 5, 2012 at 8:04 AM

Hi to everybody,

this is the situation i've 2 Vlan with this architecture:

  1. 192.168.50.xx/24
  2. 192.168.1.xx/24

with the 3.1 version i don't have problem to connect the pc's of that 2 VLAN:

I've use this configuration's file:

One pc of VLan 192.168.50.xx/24:

 

 <BridgeConfiguration>
    <internalservicebinding ip="192.168.50.180" port="1235"/>
    <externalservicebinding ip="192.168.50.180" port="1236"/>
    <channelbinding ip="224.10.11.12" mport="9998" sport="9997"/>
    <targets>
      <add ip="192.168.1.106" port="1236"/>
    </targets>
 </BridgeConfiguration>

 

 

One pc of VLan 192.168.1.xx/24:

 

 <BridgeConfiguration>
    <internalservicebinding ip="192.168.1.106" port="1235"/>
    <externalservicebinding ip="192.168.1.106" port="1236"/>
    <channelbinding ip="224.10.11.12" mport="9998" sport="9997"/>
    <targets>
      <add ip="192.168.50.180" port="1236"/>
    </targets>
  </BridgeConfiguration>

 

remember this with the 3.1 version and i don't have problem. All pc are visible.

With the last version i use this configuration file:

One pc of VLan 192.168.50.xx/24:

 

 <BridgeConfiguration>
    <InternalServiceBinding IP="192.168.50.180" Port="1235"/>
    <ExternalServiceBinding IP="192.168.50.180" Port="1236"/>
    <PresenceBinding MulticastIP="224.10.11.12" MulticastPort="9998" ServicePort="9997" PresenceCallbackPort="9996" />
    <Targets>
      <add IP="192.168.1.106" Port="1236"/>
    </Targets>
  </BridgeConfiguration>

 

On pc of VLan 192.168.1.xx/24:

 

 <BridgeConfiguration>
    <InternalServiceBinding IP="192.168.1.106" Port="1235"/>
    <ExternalServiceBinding IP="192.168.1.106" Port="1236"/>
    <PresenceBinding MulticastIP="224.10.11.12" MulticastPort="9998" ServicePort="9997" PresenceCallbackPort="9996" />
    <Targets>
      <add IP="192.168.50.180" Port="1236"/>
    </Targets>
  </BridgeConfiguration>

With this configuration the Console Window of Squiggle.Bridge remain in this mode:


Uploaded with ImageShack.us

And:


Uploaded with ImageShack.us

Please help me.....

Coordinator
Sep 9, 2012 at 7:41 PM

Did you also update the client machines with latest version of Squiggle? The version of Squiggle available in source code is not compatible with old clients. You can't run a new bridge with old clients or new clients with old bridge.

Sep 10, 2012 at 7:11 AM
Edited Sep 10, 2012 at 7:24 AM

Hi hasankhan, thanks a lot for your answer.

I use this version of client:


Uploaded with ImageShack.us

 

Bye.